Mô hình bài LAB:
Yêu cầu:
- Cấu hình OSPF single area
- Qủang bá các loopback interfaces
- Xác nhận lại việc thiết lập neighbor
- Chỉnh sửa OSPF link cost trên các interfaces
- Chỉnh sửa OSPF priorities
- Sử dụng công cụ debug để xem việc trao đổi thông tin
R1:
------------------------
R1#show run
Building configuration...
<...output omitted...>
hostname R1
!
!
interface Loopback1
ip address 10.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.200.1 255.255.255.0
ip ospf cost 5 <<< thay đổi OSPF cost trên interface
ip ospf priority 5 <<< thay đổi OSPF priority trên interface
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.100.1 255.255.255.0
ip ospf cost 50
clock rate 2000000
!
<---- cấu hình OSPF----->
router ospf 10
log-adjacency-changes
network 10.1.1.0 0.0.0.255 area 0
network 10.1.100.0 0.0.0.255 area 0
network 10.1.200.0 0.0.0.255 area 0
!
<...output omitted...>
end
------------------------
R2:
------------------------
R2#show run
<...output omitted...>
!
hostname R2
!
interface Loopback2
ip address 10.1.2.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.200.2 255.255.255.0
ip ospf cost 5
ip ospf priority 6
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.100.2 255.255.255.0
ip ospf cost 60
clock rate 64000
!
router ospf 10
log-adjacency-changes
network 10.1.2.0 0.0.0.255 area 0
network 10.1.100.0 0.0.0.255 area 0
network 10.1.200.0 0.0.0.255 area 0
!
end
<...output omitted...>
<...output omitted...>
!
hostname R2
!
interface Loopback2
ip address 10.1.2.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.200.2 255.255.255.0
ip ospf cost 5
ip ospf priority 6
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.100.2 255.255.255.0
ip ospf cost 60
clock rate 64000
!
router ospf 10
log-adjacency-changes
network 10.1.2.0 0.0.0.255 area 0
network 10.1.100.0 0.0.0.255 area 0
network 10.1.200.0 0.0.0.255 area 0
!
end
<...output omitted...>
----------------------
R3:
---------------------
R3#show run
Building configuration...
<...output omitted...>
!
hostname R3
!
interface Loopback3
ip address 10.1.3.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.200.3 255.255.255.0
ip ospf cost 5
ip ospf priority 7
duplex auto
speed auto
!
router ospf 10
log-adjacency-changes
network 10.1.3.0 0.0.0.255 area 0
network 10.1.200.0 0.0.0.255 area 0
!
<...output omitted...>
end
---------------------
Xác thực lại kết nối neighbors
R1#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
10.1.2.1 0 FULL/ - 00:00:39 10.1.100.2 Serial0/0
10.1.2.1 6 FULL/DR 00:00:38 10.1.200.2 FastEthernet0/0
10.1.3.1 7 FULL/BDR 00:00:32 10.1.200.3 FastEthernet0/0
Xem lại thông tin OSPF trên từng interfaces
-----------------------
R1#show ip ospf interface fa0/0
FastEthernet0/0 is up, line protocol is up
Internet Address 10.1.200.1/24, Area 0
Process ID 10, Router ID 10.1.1.1, Network Type BROADCAST, Cost: 5
Transmit Delay is 1 sec, State DROTHER, Priority 5
Designated Router (ID) 10.1.2.1, Interface address 10.1.200.2
Backup Designated router (ID) 10.1.3.1, Interface address 10.1.200.3
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:04
Supports Link-local Signaling (LLS)
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 2, Adjacent neighbor count is 2
Adjacent with neighbor 10.1.2.1 (Designated Router)
Adjacent with neighbor 10.1.3.1 (Backup Designated Router)
Suppress hello for 0 neighbor(s)
----------------------
Sử dụng công cụ debug
R1#debug ip ospf packet
OSPF packet debugging is on
R1#
*Mar 1 01:13:45.087: OSPF: rcv. v:2 t:1 l:48 rid:10.1.2.1
aid:0.0.0.0 chk:D591 aut:0 auk: from Serial0/0
*Mar 1 01:13:47.599: OSPF: rcv. v:2 t:1 l:52 rid:10.1.3.1
aid:0.0.0.0 chk:2482 aut:0 auk: from FastEthernet0/0
*Mar 1 01:13:54.027: OSPF: rcv. v:2 t:1 l:52 rid:10.1.2.1
aid:0.0.0.0 chk:2483 aut:0 auk: from FastEthernet0/0
*Mar 1 01:13:55.043: OSPF: rcv. v:2 t:1 l:48 rid:10.1.2.1
aid:0.0.0.0 chk:D591 aut:0 auk: from Serial0/0
*Mar 1 01:13:57.627: OSPF: rcv. v:2 t:1 l:52 rid:10.1.3.1
aid:0.0.0.0 chk:2482 aut:0 auk: from FastEthernet0/0
Ý nghĩa các thông tin trong lệnh debug
- v: version của OSPF đang chạy
- t:type (1:Hello...)
- l: length của packet (theo bytes)
- rid: router id gửi packet
aid: area id - chk: checksum
- aut: authentication (0: no authentication, ...)
Sau khi đã đổi priority, việc bầu chọn sẽ không được chạy lại từ đầu. Muốn việc bầu chọn chạy lại, sử dụng câu lệnh clear ip ospf process.
Hoặc có thể shutdown một cổng sau đó no shutdown cổng đó để xem lại việc bầu chọn.
No comments:
Post a Comment